Création de la carte SD

Pour créer la carte SD, il suffit d'utiliser Etcher disponible ici : https://www.balena.io/etcher

Premier démarrage

Avant de continuer, il faut savoir que l'adresse IP fixée par défaut pour OpenWrt est 192.168.1.1. Cette adresse est fort probablement la même que celle donnée à votre Box Internet.

Il faut donc changer cette adresse avant de mettre la Rasperry Pi en réseau.

On démarre une première fois la carte Raspberry en la reliant directement en filaire à la prise ethernet du poste de travail. Il faut d'abord s'assurer que le poste de travail est en adressage dynamique ou bien qu'il ait une adresse fixe compatible.

Ensuite on se connecte en ssh pour modifier le fichier /etc/config/network

$ ssh root@192.168.1.1

WARNING : On vous informe que le compte root n'a pas de mot de passe par défaut sur OpenWrt. Il faut sécuriser ce compte sans tarder.

# passwd

Maintenant que le compte root est sécurisé, on modifie le fichier network

# vi /etc/config/network

(commandes de vi : Ins = édition, Echap = sortie d'édition, :w = sauvegarder, :q = quitter)

Il faut changer l'adresse IP, déclarer la passerelle (gateway = IP Box Internet) et le serveur DNS.

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd81:108b:2659::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0'
option proto 'static'
option ipaddr '192.168.1.13'
option netmask '255.255.255.0'
option gateway '192.168.1.1'
option dns '192.168.1.1'
option ip6assign '60'



Mise en réseau et configuration

On peut brancher la carte Raspberry dans le réseau et redémarrer.

L'interface web n'est pas disponible par défaut, il faut l'installer via une connexion ssh sur la nouvelle adresse IP.

$ ssh root@192.168.1.13

Installation l'interface Web LuCi :

# opkg update
# opkg install luci
# opkg install luci-ssl

Ajoutons la prise en charge du français dans LuCi :

# opkg install luci-i18n-base-fr

On redémarre LuCi :

# /etc/init.d/uhttpd restart

OpenOwrt est maintenant installé et accessible via un portail web. Nous allons pouvoir passer à la configuration.

CONFIGURATION

Première connexion web

Il suffit maintenant d'ouvrir l'adresse https://192.168.1.13 dans un navigateur.

Désactivation du serveur DHCP

On commence par finaliser le paramétrage de l'interface LAN en allant sur la page Réseau > Interfaces.

On édite l'interface LAN :

En principe l'adresse IP, le masque, la passerelle et le serveur DNS sont déjà déclarés.

Dans Serveur DHCP il faut cocher Ignorer l'interface pour désactiver le serveur DHCP qui entre en conflit avec celui de la box.

Ensuite on clique sur l'onglet IPv6 Settings et on met tout sur disabled.

Enfin on clique sur Sauvegarder et Appliquer

Redémarrer OpenWRT (Système > Redémarrage) et vérifier que les modifications aient bien été enregistrées.

Configuration du Wifi

(Inspirée par les conseils donnés ici : https://support.apple.com/fr-fr/HT202068)

Dans Réseau > Sans-fil, sur la ligne SSID, cliquer sur Editer.

Configuration de l'équipement - Configuration générale :



Configuration de l'équipement - Paramètres avancés :

  • Code Pays : FR-France
  • Ne pas cocher Force 40 MHz mode



Configuration de l'interface - Configuration générale :

  • Mode : Point d'accès
  • ESSID : un nom de votre choix
  • Réseau : bien laisser Lan
  • Ne pas cocher : Cacher le ESSID
  • Cocher : Mode WMM



Configuration de l'interface - Sécurité des réseaux sans-fil :

  • Chiffrement : WPA2-PSK
  • Code de chiffrement : Forcer CCMP (AES) (c'est le cryptage le plus solide à ce jour)
  • Clé : une clé de votre choix (il faut mettre une clé wifi suffisamment forte)



Activation du WiFi :

On peut maintenant activer le wifi en cliquant sur Activer dans la zone de configuration de l'équipement.

On valide le tout en cliquant sur Sauvegarder et Appliquer

On redémarre OpenWrt pour vérifier la conservation du paramétrage du Wifi.

CREATION D'UNE IMAGE DE RESTAURATION

Dans Système > Sauvegarde / Mise à jour, il suffit de Construire l'archive qui se télécharge sur votre poste.

Attention, il ne s'agit que sauvegarde des paramètres qui n'inclut pas les paquets installés.

(article en cour d'édition ...)